Profile Picture

Indicator doesn't show up in panel

Posted By SysInv 6 Years Ago
Posted Wednesday September 05 2012
I'm trying to create a custom indicator, and wanted to try the samples first to make sure it worked - but I've encountered a few problems.

If we use the "Average Price" indicator from the help file, there are a few types that are not supported anymore. This was "List" if I remember it correctly, and after looking at other samples that used Rlist instead i managed to get it to compile. However after putting the DLL in the plugin folder and restarting RightEdge, it does not show in the indicator panel.

I tried the samples in the C# folder as well, which was an OBV. This one compiled after I change .NET 2 to .NET 3.5 in the settings, but this one does not appear in the indicator panel as well. The OBV refer to the sample group (while the Average Price was in the trend group), but no "sample" group shows (and it's not in any other group).

I noticed that the two samples use different parameter settings to indicate it's an indicator - the Average Price sample uses YYEIndicatorAtribute while the OBV use Indicator instead. I'm not sure if one is referring to an older implementation of RE?

What do you think could be wrong - why doesn't it show up in the indicator panel? The DLL's compile, I"m placing them in the plugin folder and start RE. According to the instructions this should be enough?
Posted Monday October 08 2012

Im having the same problem here. I wanted to make a simple indicator what doesnt do anything just to show up in the indicator panel. I have followed the steps written in the help, included the common.dll, writing the attributes, and implementing the IIndicator interface, it compiled succesfully, but doesnt show up in the indicator panel. What can be the problem? have you figured it out?
Im using the build 44 RightEdge trial version and the YYEIndicator attribute. Included the common.dll file from the application folder and implemented all the methods form the RightEdge.Common.IIndicator itnerface. Builded the assambly and copied it to the plugin folder, restarted the Rightedge and nothing happend... What am i doing wrong?
Posted Monday October 08 2012
The most common cause for this is that the library is being compiled for .NET 4 or higher, and RightEdge by default needs it to be compiled for 3.5. If that's not the case, follow the instructions here to get a log of what plugins aren't loading and why.


Similar Topics

Reading This Topic

2005-2018 © RightEdge Systems