Profile Picture

TWS Untracked Orders

Posted By alpha23 5 Years Ago
Message
Posted Friday September 28 2012
Orders which contain a trailing stop are not being tracked (not sure if that is where the problem is but it is different from what I’ve done in the past). Orders were placed but fills were not tracked. My TWS plugin code is based off of at least build 35.

Below is some of the TWS log file. Can you provide any insight into how to fix? I had 100+ positions open today which took an hour to enter manually into a “backup live open positions file”. I only mention to emphasize how painful it can be when the tracking code between IB and RE has a bad day.

Thanks, Duane

2012-09-27 00:15:29.6331   DFS   6894   161   OrderStatusPreSubmitted   Order status updated
2012-09-27 06:15:08.7250   DFS   6894   161   OrderStatusSubmitted   Order status updated
012-09-27 07:41:50.3013   DFS   6894   161   ExecDetails   20120927 07:41:50 Sold Size: 100 Price: 38.26
2012-09-27 07:41:50.3043   DFS   6894   161   ExecDetails   Partial fill: total 100/103
2012-09-27 07:41:50.3293   DFS   6894   161   OrderStatusSubmitted   Order status updated
2012-09-27 07:41:50.4303   DFS   6894   161   OrderStatusSubmitted   Order status updated
2012-09-27 07:41:50.4783   DFS   6894   161   ExecDetails   20120927 07:41:50 Sold Size: 3 Price: 38.26
2012-09-27 07:41:50.4783   n/a   6894   n/a   OrderStatusFilled   Order ID not currently tracked by TWS plugin.
2012-09-27 07:41:50.4963   n/a   6894   n/a   OrderStatusFilled   Order ID not currently tracked by TWS plugin.

Edited: Friday September 28 2012 by alpha23
Posted Wednesday October 17 2012
please let me know.

Duane
Posted Thursday November 08 2012
I don't see anything wrong with the log there. When an order is filled, TWS sends both ExecDetails and OrderStatus events. The TWS plugin only uses the information from ExecDetails in order to process a fill. When this results in an order being entirely filled, it is removed from the list of active orders, and subsequent messages about it sent by TWS will show up as "Order not currently tracked" in the logs.

So if this order wasn't registered by RightEdge, I'm not sure why that happened. Are you still having this same problem with trailing stop orders?

Also, it sounds like you've customized your TWS plugin somewhat. If there's nothing proprietary in it, would you mind posting the code for that so I can see exactly what's running on your system?

Thanks,
Daniel
Posted Friday November 09 2012
I will retest in conjunction with the recommendations from the other post next week.

I do have proprietary code in the plugin so I can't post. However, we should be able to resolve any issue through logging.

Thanks, Duane


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems