Profile Picture

LicenseFile Parameter Issue

Posted By thinkjohn 3 Years Ago
Message
Posted Monday November 17 2014
We are having an issue with the LicenseFile parameter on a new install.

We have 3 machines sharing the same VS2010 Solution that is on the network.  We are moving one of our users to a new macine and trying to run the solution the same way but are getting some errors.

We install RightEdge, License it correctly and then Save the License to the users local path.  RightEdge runs fine.

Then we open the solution and Run the project with the following settings (this works on all other licensed machines):
/P:"S:\Trading - 2014\RightEdge\StrategyMovingAverage250\StrategyMovingAverage250.rep" /SettingsFolder:"S:\Trading - 2014\RightEdge\SettingsFolder" /LicenseFile:"%APPDATA%\Yye Software\RightEdge\2010.1.0.0\RightEdge.lic"

RightEdge runs and I get the dialog that RightEdge is not licensed.  I click the Load License button and navigate to the RightEdge.lic file in the above path and I get the following error:

http://www.rightedgesystems.com/forums/uploads/images/32145703-2f55-47db-91e3-f3e2.jpg

Does anyone know how to solve?
Posted Monday November 17 2014
Check user file writing permissions for this directory. The alert message is about file writing permissions and has nothing to do with a valid or invalid license file.
Posted Tuesday November 18 2014
It looks like the %APPDATA% environment variable may not be defined on the machine where this is failing, or may not be getting substituted in the command line correctly.

Thanks,
Daniel
Posted Tuesday November 18 2014
It looks like it is a rights issue.  We turned UAC off and we were able to save the license file.

The %APPDATA% path is set on the machine, but it is not correctly handled when passed as a parameter.

LicenseFile Parameter Issue
:"%APPDATA%\Yye Software\RightEdge\2010.1.0.0\RightEdge.lic"


How can I access the CURRENT USERS license file with a parameter?  Have you guys tested this out?  I need the correct syntax so that each user can access a solution on the network and pass their own license file as a parameter.

John

Posted Friday November 21 2014
Are you saying you got it working now?

Also, are you saying that %APPDATA% was handled correctly on other machines but not on the new one?

Thanks,
Daniel


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems