Profile Picture

Problems with OEC and IQfeed on build 53

Posted By NNNKT 5 Years Ago
Posted Monday December 15 2014
I have some issues with build 53 on my Windows 7 cumputer.

Same OEC connection problem as before:
Login Failed: SoftwareNotPermitted

IQfeed plugin problem with multiple symbols (worked fine in build 49):
If I use 1 symbol everything works fine (both historical download and live data)!!
If I have 2 symbols or more, the first symbol gets downloaded, but then it comes to the next one the plugin crashes. It also crashes with live data on multiple symbols. This happens on all time frames I have tested.
Error msg: The service plugin IQfeed.IQfeedService threw an exception of type System.ObjectDisposedException

I did a fresh a install on a complete new Windows 2012 server (just for testing):
Same problems occur, and a new one: No system result get displayed after the simulation!
It seems like the system plugin is missing (the systemresult.dll file is in the plugin folder). I don't know if this is because of windows2012 or a fresh install.

Posted Thursday December 18 2014
Hi Christian

I've seen multiple symbol download problem with IQFeed in b52 and have reported it to Daniel.

Posted Friday December 19 2014
Thanks for the update! Good to know that I'm not the only one with this problem.
Posted Tuesday December 23 2014
Hi Christian,

I've fixed the IQFeed issue when downloading historical data for multiple symbols will fail for all but the first.

For the missing system results, go to the "System Results" tab of the RightEdge options.  There should be a list of available system results pages which you can enable.

I'm not sure why the OEC plugin still isn't working.  I've emailed the OEC API support about it.

Posted Monday December 29 2014
Actually the system results tab in options is blank.
Posted Tuesday December 30 2014
Hi Christian,

I've tried installing RightEdge on Windows Server 2012 and saw the same problem with the system results as you.  I will investigate what is the problem.

OEC API support replied and said that they've now enabled RightEdge for your account.  Can you try using the plugin again?

Posted Wednesday December 31 2014
I've figured out what the problem with System Results plugins not showing up on Windows Server 2012 is.  It will be fixed in the next build.  As a workaround, if you install .NET Framework 3.5, the issue should go away.

Posted Friday January 02 2015
The OEC API connection seems bee working fine now !!!!
The only issue is that I'm getting "Data was dropped, because out of order" when subscribing to 2 symbols or more live. With one symbol I have no issues at all. Maybe this is because of my local time zone.  Anyway, I'll be using IQfeed as my data provider, so this is no issue for me personally.

Great support, Thank you!!

Posted Thursday January 22 2015
Hi Daniel,

I recently started evaluating RightEdge, and so far it looks great.  I am now trying to connect it to an OEC demo account (14 day trial), and I'm encountering the same issue that Christian did:

Login Failed: SoftwareNotPermitted

Do we need to contact OEC support to ask them to enable the demo account for RightEdge?  Is there a way to open an OEC demo account through some other link (perhaps on your RightEdge website?), so that the use of a 3rd party platform like RightEdge will already be enabled?

Thanks in advance!

Posted Friday January 23 2015

I'm not sure what the process is to enable RightEdge on an OEC account.  I've asked my contact at OEC about it.  However, it looks like he won't be available until the 27th, so you may also want to try contacting OEC support yourself.


Similar Topics

Reading This Topic

2005-2019 © RightEdge Systems