Profile Picture

ADX in V1.2

Posted By kaizen 9 Years Ago
Message
Posted Saturday February 23 2008
I think the ADX may be broken in version 1.2. I have tried adding in via code and via the drag and drop and both show NaN for all values.



Posted Sunday February 24 2008
Well, it works for me...

Can you try just opening a quick chart and dragging the ADX onto it?  Do you get valid values?  Can you try creating a new system from scratch and add the ADX to it (without any other logic) and see if you get values?

Thanks,
Daniel

Posted Monday February 25 2008
OK. Got it working. Not sure what it was but had to create a new project and then copy the code across.



Posted Thursday March 06 2008
Actually take that back. It seams to work randomly. The attached pic shows th ADX not working. I ran a system > double clicked on a trade to view the chart then dragged the ADX(14) and all default settings onto the chart. The result is NaN for the whole ADX. I think I have seen the ATR do it as well.







Attachments
ADX.JPG (329 views, 122.00 KB)
Posted Thursday March 06 2008
I still haven't been able to reproduce this.  My best guess at this point is that it is dependent on the bar data (ie in some cases it works OK, others it gives all NaNs).  Do you consistently get this when you run it for EUR/USD with the same start date?  If so, can you send us your EUR/USD data and tell us the date of the first bar in the chart when you get the NaNs?

Thanks,
Daniel



Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems