Profile Picture

Bad service plugin causes RE to lose connected state

Posted By mark0419 9 Years Ago
Message
Posted Friday May 09 2008
While continuing work on my service plugin, I ran into a little GUI bug. The plugin I'm writing depends on some other assemblies, which I had neglected to rebuild on a test run Doze
History retrieval worked fine as there was no dependency there, but attempting to start live mode yielded this error:

There were errors starting live data retrieval for the following symbols:
GBP/USD: A service with the specified name () does not exist. It may have been renamed. Please set the new service name by configuring this folder.

OK, the message is a little off, but at least RE kicked back an error and stopped. The live mode did not engage on the toolbar, the start buttons were still active, and all other live mode buttons were still disabled.
However, when I selected the 'symbol information' for the symbol I had tried to start streaming RE poped up a dialog to tell me:

The symbol is currently streaming. in order to save changes....

Rebuilding my assemblies/service plugin caused the initial problem to go away

Cheers!
Mark
Posted Friday May 09 2008
After further digging, this had nothing to do with my assemblies. It has to do with the service selection on the watchlist folders. I had accidentally selected two folders. One of these folders has the live data service set to 'none', the other is the valid service I was testing.

When first clicking 'Start Live Data' the valid service does start streaming, there is a symbol in the live data pane and selecting this symbol's information gives the 'currently streaming' message. It seems that it's the folder set to 'none' that generates the 'no service could be found' error.

When this error occurs the toolbar remains in a 'disconnected' state, instead of going live to match the symbol that did start streaming.

Pressing the 'Start Live Data' button at this point goes through without the original 'no service could be found' error.

Cheers!
Mark
Posted Friday May 09 2008
So it sounds like the bug or at the very least, common courtesy here, would be to prevent one from starting a live system or live data with two different services.  Since we don't support this anyhow, I'll log an incident to simply disallow it.


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems