Profile Picture

Problem with sending orders with Interactive brokers

Posted By omri1181 6 Years Ago
Message
Posted Monday May 02 2011
im using the DEMO of interactive brokers. simply wrote simply system in rightedge to check if its working with IB
the stock is GOOG
i'm getting live data, seeing the ticks coming in,
when sending an order, it showing in open,pending, and then goes to closed. in rightedge everything looks like its working.
BUT in trad station of IB, i don't see ANY orders in trade log. i also added GOOG in API window there just in case.
API is enabled, also disabled firewall just in case (i got ticks also with firewall)
it looks like rightedge is managing some positions, but its not REALLY connected to IB software, which is open all the time.
i ordered GOOG through IB software, no problem, even saw orders in the trade log.



   public override void NewBar()
   {
      // Put your trading code here
      GoMKT(1,500,PositionType.Long,700);
   }
   public void GoMKT(int Size,double StopLoss,PositionType ThisPositionType,double Profit)
   {                  

         if(Size>0)
            {      
               PositionSettings posSettings = new PositionSettings();
               posSettings.PositionType = ThisPositionType;
               posSettings.OrderType = OrderType.Market;
               posSettings.Size = Size;
               posSettings.BarsValid = 10; //' Open position order is valid For 5 bars
               if(StopLoss > 0)
               {
                  posSettings.StopLoss = StopLoss;
                  posSettings.StopLossType = TargetPriceType.AbsolutePrice;
               }
               if(Profit > 0)
               {
                  posSettings.ProfitTarget = Profit;
                  posSettings.ProfitTargetType = TargetPriceType.AbsolutePrice;            
               }
               OpenPosition(posSettings);

               posSettings = null;
               //LogFile.Write("OpenPosition : Size " + Convert.ToString(Size) + " StopLoss " + Convert.ToString(StopLoss) );   

            }

   
   }
Posted Monday May 02 2011
You may be getting data from IB but using the paper broker for your trades. In your folder settings, what is the Broker Service set to?

It's also possible that the issue is with using IB's demo account. It is fairly limited and some things don't work the same. If you have an account with them and use the simulation mode, it's much more similar to live trading.

Thanks,
Daniel
Posted Monday May 02 2011
ohh ofcourse..i missed it. thank you!! also fast reply
looks like its working


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems