Profile Picture

RE not supporting DLLs build with MS Visual Basic 2010 Express, MS .NET Framework Version 4

Posted By willy 6 Years Ago

RE not supporting DLLs build with MS Visual Basic 2010 Express, MS...

Message
Posted Thursday November 24 2011
With help of MS Visual Basic 2010 Express which contains MS .Net Framework Version 4 I build a new indicator class dll. I put the dll from the Release directory into RE Plugin directory and restartet RE. I assumed that now a ne indicator should be available in group "Other" but it was not visible there.

In the RE project tree I selected References right click to reference to the new dll and got the following error message.

Not a valid .NET library, error: Die Datei oder Assembly "C:\Program Files (x86)\Yye Software\RightEdge 2010\Plugins\ClassLibrary1.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Die Assembly wird von einer Laufzeit erstellt, die aktueller als die derzeit geladene Laufzeit ist, und kann nicht geladen werden.

Translation!

Not a valid .NET library, error: The file or assembly "C:\Program Files (x86)\Yye Software\RightEdge 2010\Plugins\ClassLibrary1.dll" or a dependancy could not be found. The assembly was created with a run time environment, which is newer than the actually loaded run time environment, and therefore could not be loaded.

Need some advice how to procceed!

Attachments
ClassLibrary1.zip (248 views, 315.00 KB)

Edited: Thursday November 24 2011 by willy
Posted Thursday November 24 2011
use .Net 3.5


Posted Friday November 25 2011
Hi,

yes I detected the problem yesterday evening by myself and changed the target to .NET 3.5 in my development environment. Afterwards the dll was accepted by RE.

Thanks
willy


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems