Profile Picture

Developing/Compiling plugins with two RE versions installed on the same computer

Posted By lksf 5 Years Ago

Developing/Compiling plugins with two RE versions installed on the...

Message
Posted Tuesday July 03 2012
I have a computer which has both RE 2008 and RE 2010 installed, I am trying to compile the RightEdgePlugins folder (of the 2010 version) but the references to "Common" keep changing to RE2008's common because (i guess) it is strongly signed or something like that.

How can I resolve this and force my projects to reference the correct version of common.dll?


I would add that I have other VS solutions which are intended for the old 2008 version and are referencing its common.dll and I don't want them to change, they should keep referencing the 2008 version.

Thanks
Posted Tuesday July 03 2012
Copy the version of Common.dll you want to compile against into the RightEdgePlugins\DLLs folder. That's where the projects are looking for it, but since it's not there, it is picking up what it can find from somewhere else (probably the GAC).

For the next build I've updated the installer to put Common.DLL in that directory, which should fix the issue.

Thanks,
Daniel
Posted Tuesday July 03 2012
Thank you for that, solved 98% of the errors. :-)

Now I'm missing SQLDataContext.dbml and SQLDataContext.dbml.layout to build the project DataStorage

Any ideas?
Posted Wednesday July 04 2012
Here are those files. They will be included in the installation in the next build.

Thanks,
Daniel

Attachments
SQLDataContext.dbml.zip (231 views, 1.00 KB)


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems