Profile Picture

Live Trading Error: Does not Seem to Trade

Posted By ywlee 2 Years Ago
Message
Posted Friday May 15 2015
Hi

A few issues with live trading for forex pairs.

1/ Using IQFeed as Live Data Feed.  

I'm using 5 min bars with broker set to IB and live data set to IQFeed.  Trading strategy is a simple EMA CrossOver using 24 bars.

Simulation is fine with the trading strategy.  Downloading historical data is also fine.

However, when I connect to live trading the following is observed:

a/ IB API tab does not show the connection
b/ Only Last Price is updated but rest of the values (bid, ask, last volume etc) are not updating after the initial value is shown (even after 3 hours - I assumed it needed to gather data for 2 hours because 24 bars x 5 min)
c/ No trading is done eventhough the cross over triggers many times on IB's chart
d/ When I click on the symbol, sometimes I get the the bar chart.  Other time I need to purge all the historical data from the symbol otherwise  I get a "tick out of order" error.

2/ Using IB as Broker and LIve Data

a/ Bid, Bid Size, Ask, Ask Size, is updated but Volume and Last Price is always 0 / 0.0000 even after 3 hours.
b/ When I click on the graph, I get only the historical data. No additional bars are added even after a few hours.

In both cases above, there are no Output error messages so I'm not sure what is wrong.

Thanks in advance.



Posted Tuesday May 19 2015
Managed to sort it out....it was due to the timestamp coming in from IQFeed and the local time.


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems