Profile Picture

RightEdge won't start after Windows update

Posted By ywlee 2 Years Ago
Message
Posted Friday June 05 2015
Hi

After a windows autoupdate, I can't start RightEdge.  Have uninstalled and reinstalled and the same error message appears.

An exception of type System.Configuration.ConfigurationErrorsException was thrown.
Root element is missing. (C:\Users\ywlee_000\AppData\Roaming\Yye_Software\RightEdge.exe_StrongName_tzopmoluzdyjreykcjm2jskkq1rnwoju\2010.1.0.0\user.config)
 at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
 at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
 at System.Configuration.Configuration..ctor(String locationSubPath, Type typeConfigHost, Object[] hostInitConfigurationParams)
 at System.Configuration.ClientConfigurationHost.OpenExeConfiguration(ConfigurationFileMap fileMap, Boolean isMachine, ConfigurationUserLevel userLevel, String exePath)
 at System.Configuration.ConfigurationManager.OpenExeConfigurationImpl(ConfigurationFileMap fileMap, Boolean isMachine, ConfigurationUserLevel userLevel, String exePath, Boolean preLoad)
 at System.Configuration.ConfigurationManager.OpenExeConfiguration(ConfigurationUserLevel userLevel)
 at RightEdge.AppMain.x3608845793721ba5()
 at RightEdge.AppMain.Main(String[] args)

Inner Exception:
An exception of type System.Xml.XmlException was thrown.
Root element is missing.
 at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
 at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
 at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
 at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
Posted Friday June 05 2015
It looks like a RightEdge configuration file is corrupted.  Try deleting the file it mentions: C:\Users\ywlee_000\AppData\Roaming\Yye_Software\RightEdge.exe_StrongName_tzopmoluzdyjreykcjm2jskkq1rnwoju\2010.1.0.0\user.config

Thanks,
Daniel
Posted Friday June 05 2015
Thanks for the reply.

I did delete the file it mentions and uninstalled RE and installed again but had the same error message.

WIll it help if I installed RE in another location other than RightEdge 2010?
Posted Friday June 05 2015
Try also deleting the following file:

C:\Users\ywlee_000\AppData\Local\Yye_Software\RightEdge.exe_StrongName_tzopmoluzdyjreykcjm2jskkq1rnwoju\2010.1.0.0\user.config

If that doesn't work, try deleting the following two folders:

C:\Users\ywlee_000\AppData\Local\Yye_Software\
C:\Users\ywlee_000\AppData\Roaming\Yye_Software\

If that doesn't work, try also deleting RightEdge.exe.config from the RightEdge installation directory and reinstalling RightEdge again.

Thanks,
Daniel
Posted Sunday June 07 2015
Thanks. Deleting the file from /local worked.

Was able to start up again.



Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems