Profile Picture

Live Data Not Working

Posted By ywlee Last Year
Message
Posted Sunday March 13 2016
Hi 

I configured a futures symbol for IB using the wizard and it downloads the historical data without issue.  However it does not register any live data when live trading is turned on.

I can see the live data on IB and when I collect the historical data again on RE, I'm able to capture the new bars since the last update.  However, Live Data still does not work. I tried loading the back month of the same future and it works fine.

Are there any situations where the live data will not work?  The Live Data columns just shows "0" for every column.

Thanks in advance.
Posted Monday March 14 2016
I think I may have narrowed down the issue. Its possible that TWS IB is sending too much data and has timed out.  The data works fine when the frequency of the data is slower but cant seem to keep up (and shows 0) when the data frequency increases.  Is there any way to mitgate this?  
Posted Friday March 25 2016
I've just released a new version of RightEdge, and one of the changes is that the TWS plugin will create logs for the data connection (previously it would only create logs for the broker functions).  Can you update to the new version, make sure logging is enabled for the TWS plugin, and then when you see this problem look in the DataLogs folder under the TWSLogs and send me the corresponding log file?

Thanks,
Daniel

Edited: Friday March 25 2016 by dplaisted


Similar Topics


Reading This Topic


2005-2017 © RightEdge Systems